MikroTik Weighted Static Routes

MikroTik Weighted Static Routes

This post is how to setup weighted static routes using Google DNS as a reference. Here we are setting a weight of 1 to 8.8.8.8 using 192.168.88.1 and a weight of 10 using 192.168.60.1. You can adapt the dst-address to whatever subnet you need to add routes for.

/ip route
add check-gateway=ping disabled=no distance=1 dst-address=8.8.8.8/32 gateway=\
    192.168.88.1 pref-src=0.0.0.0 routing-table=main scope=30 \
    suppress-hw-offload=no target-scope=10
add check-gateway=ping disabled=no distance=10 dst-address=8.8.8.8/32 gateway=\
    192.168.60.1 pref-src=0.0.0.0 routing-table=main scope=30 \
    suppress-hw-offload=no target-scope=10

Leave a Reply

Your email address will not be published.

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.