Disconnect MikroTik Clients When Wifi/RSSI Is Below Threshold

The following is a quick guide on how to force clients to disconnect from MikroTik access points when their RSSI or signal strength drops below a certain threshold. For this example we will be using wlan1 as our wireless interface and setting our RSSI threshold at -70. Please note that you will need to be either hardwired to the device or connected via a different wireless interface as this will disconnect you when changing the wireless settings temporarily.

  1. Disable default-authentication on wlan1. This will force authentication through our access list.
    • /interface wireless
      set [ find default-name=wlan1 ] default-authentication=no
  2. Set our Access List Policy to force clients with worse than -70 to disconnect.
    • /interface wireless access-list
      add allow-signal-out-of-range=1s interface=wlan1 signal-range=-70..120

Leave a Reply

Your email address will not be published. Required fields are marked *

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.