Mikrotik Tagged VLANs Using WiFi Interface

Mikrotik Tagged VLANs Using WiFi Interface

The following is a guide on how to setup Tagged VLANs across WiFi interfaces on MikroTik. Please note that this does not work using WifiWave2 as it does not support Station Bridge at this time. This assumes you have a bridge create called LAN_180 and are using wlan1 for the interface.

R1 Configuration Access Point Router

  1. Create the bridge if not already built.
    • /interface bridge
    • add name=LAN_180
  2. Create the WiFi Security Profile.
    • /interface wireless security-profiles
    • add authentication-types=wpa2-psk eap-methods=”” mode=dynamic-keys name=P2P supplicant-identity=”” wpa2-pre-shared-key=WIFIPASSWORD
  3. Setup the WiFi Interface.
    • /interface wireless
    • set [ find default-name=wlan1 ] band=5ghz-onlyac channel-width=20/40/80mhz-XXXX disabled=no frequency=5765 mode=ap-bridge security-profile=P2P ssid=R1SSID wps-mode=disabled
  4. Create the VLAN on the WiFi Interface.
    • /interface vlan
    • add interface=wlan1 name=vlan180-wlan1 vlan-id=180
  5. Add the VLAN Interface to the LAN_180 Bridge
    • /interface bridge port
    • add bridge=LAN_180 interface=vlan180-wlan1

R2 Configuration Station Access Point Router

  1. Create the bridge if not already built.
    • /interface bridge
    • add name=LAN_180
  2. Create the WiFi Security Profile.
    • /interface wireless security-profiles
    • add authentication-types=wpa2-psk eap-methods=”” mode=dynamic-keys name=P2P supplicant-identity=”” wpa2-pre-shared-key=WIFIPASSWORD
  3. Setup the WiFi Interface.
    • /interface wireless
    • set [ find default-name=wlan1 ] band=5ghz-a/n/ac channel-width=20/40/80mhz-Ceee \ disabled=no frequency=5765 mode=station-bridge security-profile=P2P ssid=\ R1SSID
  4. Create the VLAN on the WiFi Interface.
    • /interface vlan
    • add interface=wlan1 name=vlan180-wlan1 vlan-id=180
  5. Add the VLAN Interface to the LAN_180 Bridge
    • /interface bridge port
    • add bridge=LAN_180 interface=vlan180-wlan1

Leave a Reply

Your email address will not be published.

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.