MikroTik EOIP Site to Site

MikroTik EOIP Site to Site

MikroTik offers a solution to pass L2 Untagged or Tagged traffic using the interface type known as EOIP. Using this offers the ability to pass packets that need to be fragmented across connections that may not support the MTU required for your application. Using EOIP does require having IP addresses that are reachable and routable to and from the two endpoints. If one of the endpoints are behind a NAT a VPN connection must be used to provide a Local and Remote Address to establish the tunnel. This beyond the scope of this guide. Below is the configuration required to build a bridge for tagged and untagged traffic, build an EOIP tunnel and the required tagged VLAN, and tie the tunnel both tagged and untagged interfaces to the bridges. This configuration assumes that you already have a routable IP between the two routers not behind a NAT and does not take into account MTU limitations of your connectivity between the routers.

R1 Configuration

  1. Build the Bridges for Tagged and Untagged Traffic
    • /interface bridge
    • add name=EOIP_TAGGED_BRIDGE_60
    • add name=EOIP_UNTAGGED_BRIDGE
  2. Build the EOIP Interface
    • /interface eoip add local-address=192.168.60.1 name=eoip-tunnel1 \ remote-address=192.168.60.2 tunnel-id=60
  3. Build the Tagged VLAN on the EOIP Interface
    • /interface vlan add interface=eoip-tunnel1 name=vlan60-eoip1 vlan-id=60
  4. Add the Interfaces to the Bridge for Tagged VLAN
    • /interface bridge port add bridge=EOIP_TAGGED_BRIDGE_60 interface=vlan60-eoip1
  5. Add the Interfaces to the Bridge for Untagged Traffic
    • /interface bridge port add bridge=EOIP_UNTAGGED_BRIDGE interface=eoip-tunnel1

R2 Configuration

  1. Build the Bridges for Tagged and Untagged Traffic
    • /interface bridge
    • add name=EOIP_TAGGED_BRIDGE_60
    • add name=EOIP_UNTAGGED_BRIDGE
  2. Build the EOIP Interface
    • /interface eoip add local-address=192.168.60.2 name=eoip-tunnel1 \ remote-address=192.168.60.1 tunnel-id=60
  3. Build the Tagged VLAN on the EOIP Interface
    • /interface vlan add interface=eoip-tunnel1 name=vlan60-eoip1 vlan-id=60
  4. Add the Interfaces to the Bridge for Tagged VLAN
    • /interface bridge port add bridge=EOIP_TAGGED_BRIDGE_60 interface=vlan60-eoip1
  5. Add the Interfaces to the Bridge for Untagged Traffic
    • /interface bridge port add bridge=EOIP_UNTAGGED_BRIDGE interface=eoip-tunnel1

Leave a Reply

Your email address will not be published.

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.